VoIP + Cisco Packet Tracer



While working with the Cisco Packet Tracer program, I often noticed various telephone devices in it, as well as software on client devices, with which you can organize phone calls. In this regard, the idea arose to mock up a network consisting of all devices of this simulator (cisco packet tracer 6.2) that can make and receive calls. When writing this article, the question arose: "Is it possible to prepare for the CCNA Voice exam using this program?" And to this question, I will try to answer in this article.

Devices used:

1) Router 2811 (it will be a DHCP server, VoIP gateway and TFTP server)
2) Switch 2960 (all devices will be connected to it)
3) Analog phone (which will be connected to the switch through the gateway)
4) IP phone 7960
5) Client computer (which will work using Cisco IP Communicator software)
6) Wi-Fi point (it is needed to connect wireless devices to the network)
7) Laptop, tablet computer and smartphone (device data will be connected to a Wi-Fi point and work through CIPC)

Next, you will need the poppy addresses of all devices. For computers and other devices (not phones), there are several ways to find out the poppy address. For example, go to the device command line and type ipconfig / all or go to the config tab and copy the address of the corresponding interface to the poppy buffer.





For phones, I found only one way - to move the mouse over the device and remember its poppy (if anyone knows another way, I will be glad to know).



Set up the router:

1) Hang the ip address on the interface (it will be the gateway)

interface FastEthernet0 / 0
ip address 10.3.0.1 255.255.255.0
no shutdown


2) Next we will raise DHCP, therefore, we will exclude from the output the address hanging on our interface in advance

ip dhcp excluded-address 10.3.0.1

3) Raise DHCP

ip dhcp pool Telephony
network 10.3.0.0 255.255.255.0 (we are announcing the network)
default-router 10.3.0.1 (specify the main gateway)
option 150 ip 10.3.0.1 (specify tftp server)


4) Let's raise the telephone service and set up the number of telephones and the number of lines on it (despite the fact that we have 6 devices, we will indicate the number with a margin)

telephony-service (raise CME)
max-ephones 10 (indicate the number of phones)
max-dn 10 (specify the number of lines)
ip source-address 10.3.0.1 port 2000 (specify from which interface it will receive calls)
auto assign 1 to 10 (assign automatic assignment of lines from 1 to 10)


5) Now configure the lines

ephone-dn 1 (create a line)
number 101 (assign it a number)
!
ephone-dn 2 (create a line)
number 102 (assign it a number)
!
ephone-dn 3 (create a line)
number 103 (assign it a number)
!
ephone-dn 4 (create a line)
number 104 (assign it a number)
!
ephone-dn 5 (create a line)
number 105 (assign it a number)
!
ephone-dn 6 (create a line)
number 106 (assign it a number)


6) Now we will create telephones and bind a certain number to the poppy address of the phone
ephone 1 (for analog phone)
device-security-mode none
mac-address 0060.2FD6.7601 (MAC address of the gateway of an analog telephone)
type ata (indicates that the phone is analog)
button 1: 1 (binds this phone to the first number, i.e. 101)
!
ephone 2 (for ip phone)
device-security-mode none
mac-address 0030.A3EB.2305 (poppy ip address of the phone)
type 7960 (indicates that it is cisco 7960)
button 1: 2 (binds this phone to the second number, i.e. 102)
!
ephone 3 (for computer)
device-security-mode none
mac-address 0001.C7DE.62B5 (mac address of the computer)
type CIPC (indicates that cisco ip communicator will be used, or shortly cipc)
button 1: 3 (binds this phone to the third number, i.e. 103)
!
ephone 4 (for smartphone)
device-security-mode none
mac-address 0001.4315.ED82 (mac address of the smartphone)
type CIPC (indicates that cisco ip communicator will be used, or shortly cipc)
button 1: 4 (binds this phone to the fourth number, i.e. 104)
!
ephone 5 (for tablet)
device-security-mode none
mac-address 00D0.BC92.7B76 (tablet mac address)
type CIPC (indicates that cisco ip communicator will be used, or shortly cipc)
button 1: 5 (binds this phone to the fifth number, i.e. 105)
!
ephone 6 (for laptop)
device-security-mode none
mac-address 0001.9622.8276 (laptop mac address)
type CIPC (indicates that cisco ip communicator will be used, or shortly cipc)
button 1: 6 (binds this phone to the sixth number, that is 106)


Configure the switch:

1) Let's translate 4 switch ports that look at our devices in voice vlan

interface FastEthernet0 / 1
switchport voice vlan 1
exit
!
interface FastEthernet0 / 2
switchport voice vlan 1
exit
!
interface FastEthernet0 / 3
switchport voice vlan 1
exit
!
interface FastEthernet0 / 4
switchport voice vlan 1


Set up a VoIP gateway for an analog phone:

Since this analog phone does not know how to work with IP addresses, but it needs to get a number, it connects to the network using a gateway. For correct operation, the gateway needs to register the server address where to contact.

"

Configuring Wi-Fi

Since these portable devices do not have ethernet ports, they will work using a wi-fi point connected to a common network. Connect the point to the switch and go to its settings.

Click on the Config -> Port 1 tab and customizable (in general, you can leave the name Default and without a password):

SSID: wifi
Channel: 6
Authentication: WPA2-PSK
PSK Pass Phrase: cisco123




Now enter this data on devices that will connect via wi-fi. For example, set up wi-fi on a smartphone. Click on the tab Config -> Wireless0 and configure. Make sure that the checkbox next to port status is set to On, and DHCP is selected in the IP Configuration field.

SSID: wifi
Channel: 6
Authentication: WPA2-PSK
PSK Pass Phrase: cisco123




Obtaining addresses and setting up CIPC on devices:

At this stage, phones should already register and get numbers (in the GUI tab, the number of the received phone should appear in the upper right corner).

Analog Phone:



IP Phone 7960:



Let's go to the computer and other devices. After all the devices get IP addresses, go to the Desktop tab and select Cisco IP Communicator. After that, in the upper right corner, we see that the number is assigned (personally, I didn’t assign the number until I started CIPC myself. Either this was a bug of the simulator itself, or Cisco wanted to simulate that the number is assigned after the client starts)

But in general The picture is:

PC:



Smartphone:



Tablet:



Laptop:



As you can see, all devices received numbers, according to reservations on the router.

Performance check: The

final stage remained, in the form of organizing a phone call and connection. But checking all 6 devices and calls from each to each is impractical, since you get a whole filmstrip. Therefore, we organize a call from a tablet computer to a regular analog phone and vice versa, as well as from an analog phone to an ip phone and vice versa.

A call from a tablet to an analog phone (from 101 to 105): A



call from an analog phone to a tablet (from 105 to 101): A



call from an analog phone to an IP phone (from 101 to 102), where the handset is specially picked up for demonstration that the connection is established and conversation is possible.



A call from an IP phone to an analog phone (from 102 to 101):



Thus, a telephone connection was made, both in the structure of devices and completely different in their hardware and software architecture.

PS And now we have come to an end and it remains to answer the question asked at the beginning: "Is it possible to prepare for the CCNA Voice exam using this program?"

I will try to answer a little detailed. While writing this article, a little disappointed. Since in this simulator there is only one router, on which you can raise CME and organize telephony, this is 2811. In addition to this, the functionality of this router is cut down completely, so only the most basic things can be mocked up here. Talking about phones I think it makes no sense. Well, if we talk about the Cisco IP Communicator program itself, then here it is nothing more than a picture with a couple of buttons. Accordingly, I think that to prepare for the exam, the experience gained in this simulator will be clearly insufficient and more powerful tools will have to be used. But for a basic introduction to how tsiskovaya telephony works, she copes.
In this regard, in the future I plan to release a lesson on Cisco Call Manager or CUCM, as well as to analyze in more detail the functionality of the CIPC program.

Thank you all and good settings.

Also popular now: