How to create clear logical (L3) network diagrams
- Transfer
- Tutorial
The biggest problem that I encounter when working with enterprise networks is the lack of clear and understandable network logic. In most cases, I encounter situations where the customer cannot provide any logic circuits or diagrams. Network diagrams (hereinafter L3-diagrams) are extremely important when solving problems or planning changes in the enterprise network. Logic schemes are in many cases more valuable than physical connections. Sometimes I come across "logical-physical-hybrid" schemes that are almost useless. If you do not know the logical topology of your network, you are blind. As a rule, the ability to portray a logical network diagram is not a common skill. It is for this reason that I am writing this article about creating clear and understandable logic diagrams of a network.
In order to create a network diagram, you must have an accurate idea of what information should be present and on which particular diagrams. Otherwise, you will begin to mix information and as a result we will get another useless “hybrid” scheme. Good L3 circuits contain the following information:
The information listed below should not be on network diagrams, as it refers to other levels [ OSI models , approx. trans. ] and, accordingly, should be reflected in other schemes :
Logic circuits typically use logical symbols. Most of them do not require explanation, but because I already saw the errors of their application, then let me stop and give a few examples:
In order to create a logical network diagram, you will need the following information:
In this example, we will use a simple network. It will have Cisco and ITU Juniper Netscreen switches. We are provided with the L2 scheme, as well as the configuration files of most of the devices presented. ISP Edge Router Configuration Files Not Provided in real life, ISP does not transmit such information. Below is the L2 network topology:
And here are the device configuration files. Only the necessary information is left:
Good. Now that we have all the necessary information, we can begin to visualize.
At this point, we get a circuit similar to this:
Repeat this process step by step for each network device . Collect all information related to IP and display in the same diagram: each ip-address, each interface and each static route. In the process, your circuit will become very accurate. Make sure that devices that are mentioned but not yet known are displayed in the diagram. In the same way as we did earlier with the address 192.168.10.1 . Once you have completed all of the above for all known network devices, you can begin to find out unknown information. You can use the MAC and ARP tables for this (I wonder if it is worth writing the next post telling in detail about this stage?).
Ultimately, we will have a circuit like this:
Draw a logical diagram of the network is very simple, if you have the appropriate knowledge. This is a lengthy manual process, but it is by no means magic. Once you have an L3 network diagram, it’s easy enough to keep it up to date. The benefits are worth the effort:
What information should be presented on L3 diagrams?
In order to create a network diagram, you must have an accurate idea of what information should be present and on which particular diagrams. Otherwise, you will begin to mix information and as a result we will get another useless “hybrid” scheme. Good L3 circuits contain the following information:
- subnets
- VLAN ID (all)
- VLAN names
- network addresses and masks (prefixes)
- L3 devices
- routers, firewalls (hereinafter ITU) and VPN gateways (at least)
- the most significant servers (for example, DNS, etc.)
- ip addresses of these servers
- logical interfaces
- routing protocol information
What information should NOT be on L3 circuits?
The information listed below should not be on network diagrams, as it refers to other levels [ OSI models , approx. trans. ] and, accordingly, should be reflected in other schemes :
- all information L2 and L1 (in general)
- L2 switches (only the management interface can be represented)
- physical connections between devices
Notation Used
Logic circuits typically use logical symbols. Most of them do not require explanation, but because I already saw the errors of their application, then let me stop and give a few examples:
- Subnet represented as a tube or line:
- VRF or another zone not known exactly is represented as a cloud:
What information is needed to create an L3 circuit?
In order to create a logical network diagram, you will need the following information:
- L2 (or L1) Diagram — A representation of the physical connections between L3 devices and switches
- L3 device configurations - text files or access to the GUI, etc.
- L2 device configurations - text files or access to the GUI, etc.
Example
In this example, we will use a simple network. It will have Cisco and ITU Juniper Netscreen switches. We are provided with the L2 scheme, as well as the configuration files of most of the devices presented. ISP Edge Router Configuration Files Not Provided in real life, ISP does not transmit such information. Below is the L2 network topology:
And here are the device configuration files. Only the necessary information is left:
asw1
!
vlan 210
name Servers1
!
vlan 220
name Servers2
!
vlan 230
name Servers3
!
vlan 240
name Servers4
!
vlan 250
name In-mgmt
!
interface GigabitEthernet0/1
switchport mode trunk
switchport trunk encapsulation dot1q
!
interface GigabitEthernet0/2
switchport mode trunk
switchport trunk encapsulation dot1q
!
interface vlan 250
ip address 192.168.10.11 255.255.255.128
!
ip default-gateway 192.168.10.1
asw2
!
vlan 210
name Servers1
!
vlan 220
name Servers2
!
vlan 230
name Servers3
!
vlan 240
name Servers4
!
vlan 250
name In-mgmt
!
interface GigabitEthernet0/1
switchport mode trunk
switchport trunk encapsulation dot1q
!
interface GigabitEthernet0/2
switchport mode trunk
switchport trunk encapsulation dot1q
!
interface vlan 250
ip address 192.168.10.12 255.255.255.128
!
ip default-gateway 192.168.10.1
asw3
!
vlan 210
name Servers1
!
vlan 220
name Servers2
!
vlan 230
name Servers3
!
vlan 240
name Servers4
!
vlan 250
name In-mgmt
!
interface GigabitEthernet0/1
switchport mode trunk
switchport trunk encapsulation dot1q
!
interface GigabitEthernet0/2
switchport mode trunk
switchport trunk encapsulation dot1q
!
interface vlan 250
ip address 192.168.10.13 255.255.255.128
!
ip default-gateway 192.168.10.1
csw1
!
vlan 200
name in-transit
!
vlan 210
name Servers1
!
vlan 220
name Servers2
!
vlan 230
name Servers3
!
vlan 240
name Servers4
!
vlan 250
name In-mgmt
!
interface GigabitEthernet0/1
switchport mode trunk
switchport trunk encapsulation dot1q
!
interface GigabitEthernet0/2
switchport mode trunk
switchport trunk encapsulation dot1q
channel-group 1 mode active
!
interface GigabitEthernet0/3
switchport mode trunk
switchport trunk encapsulation dot1q
channel-group 1 mode active
!
interface GigabitEthernet0/4
switchport mode trunk
switchport trunk encapsulation dot1q
!
interface GigabitEthernet0/5
switchport mode trunk
switchport trunk encapsulation dot1q
!
interface GigabitEthernet0/6
switchport mode trunk
switchport trunk encapsulation dot1q
!
interface Port-channel 1
switchport mode trunk
switchport trunk encapsulation dot1q
!
interface vlan 200
ip address 10.0.0.29 255.255.255.240
standby 1 ip 10.0.0.28
!
interface vlan 210
ip address 192.168.0.2 255.255.255.128
standby 2 ip 192.168.0.1
!
interface vlan 220
ip address 192.168.0.130 255.255.255.128
standby 3 ip 192.168.0.129
!
interface vlan 230
ip address 192.168.1.2 255.255.255.128
standby 4 ip 192.168.1.1
!
interface vlan 240
ip address 192.168.1.130 255.255.255.128
standby 5 ip 192.168.1.129
!
interface vlan 250
ip address 192.168.10.2 255.255.255.128
standby 6 ip 192.168.10.1
!
ip route 0.0.0.0 0.0.0.0 10.0.0.17
csw2
!
vlan 200
name in-transit
!
vlan 210
name Servers1
!
vlan 220
name Servers2
!
vlan 230
name Servers3
!
vlan 240
name Servers4
!
vlan 250
name In-mgmt
!
interface GigabitEthernet0/1
switchport mode trunk
switchport trunk encapsulation dot1q
!
interface GigabitEthernet0/2
switchport mode trunk
switchport trunk encapsulation dot1q
channel-group 1 mode active
!
interface GigabitEthernet0/3
switchport mode trunk
switchport trunk encapsulation dot1q
channel-group 1 mode active
!
interface GigabitEthernet0/4
switchport mode trunk
switchport trunk encapsulation dot1q
!
interface GigabitEthernet0/5
switchport mode trunk
switchport trunk encapsulation dot1q
!
interface GigabitEthernet0/6
switchport mode trunk
switchport trunk encapsulation dot1q
!
interface Port-channel 1
switchport mode trunk
switchport trunk encapsulation dot1q
!
interface vlan 200
ip address 10.0.0.30 255.255.255.240
standby 1 ip 10.0.0.28
!
interface vlan 210
ip address 192.168.0.3 255.255.255.128
standby 2 ip 192.168.0.1
!
interface vlan 220
ip address 192.168.0.131 255.255.255.128
standby 3 ip 192.168.0.129
!
interface vlan 230
ip address 192.168.1.3 255.255.255.128
standby 4 ip 192.168.1.1
!
interface vlan 240
ip address 192.168.1.131 255.255.255.128
standby 5 ip 192.168.1.129
!
interface vlan 250
ip address 192.168.10.3 255.255.255.128
standby 6 ip 192.168.10.1
!
ip route 0.0.0.0 0.0.0.0 10.0.0.17
fw1
set interface ethernet0/1 zone untrust
set interface ethernet0/1.101 tag 101 zone dmz
set interface ethernet0/1.102 tag 102 zone mgmt
set interface ethernet0/2 zone trust
set interface ethernet0/1 ip 10.0.0.1/28
set interface ethernet0/1 manage-ip 10.0.0.2
set interface ethernet0/1.101 ip 10.0.0.33/28
set interface ethernet0/1.102 ip 10.0.0.49/28
set interface ethernet0/2 ip 10.0.0.17/28
set interface ethernet0/2 manage-ip 10.0.0.18
set vrouter trust-vr route 0.0.0.0/0 interface ethernet0/1 gateway 10.0.0.12
fw2
set interface ethernet0/1 zone untrust
set interface ethernet0/1.101 tag 101 zone dmz
set interface ethernet0/1.102 tag 102 zone mgmt
set interface ethernet0/2 zone trust
set interface ethernet0/1 ip 10.0.0.1/28
set interface ethernet0/1 manage-ip 10.0.0.3
set interface ethernet0/1.101 ip 10.0.0.33/28
set interface ethernet0/1.102 ip 10.0.0.49/28
set interface ethernet0/2 ip 10.0.0.17/28
set interface ethernet0/2 manage-ip 10.0.0.19
set vrouter trust-vr route 0.0.0.0/0 interface ethernet0/1 gateway 10.0.0.12
outsw1
!
vlan 100
name Outside
!
vlan 101
name DMZ
!
vlan 102
name Mgmt
!
interface GigabitEthernet1/0
description To-Inet-rtr1
switchport mode access
switchport access vlan 100
!
interface GigabitEthernet1/1
switchport mode trunk
switchport trunk encapsulation dot1q
!
interface GigabitEthernet1/3
switchport mode trunk
switchport trunk encapsulation dot1q
channel-group 1 mode active
!
interface GigabitEthernet1/4
switchport mode trunk
switchport trunk encapsulation dot1q
channel-group 1 mode active
!
interface Port-channel 1
switchport mode trunk
switchport trunk encapsulation dot1q
!
interface vlan 102
ip address 10.0.0.50 255.255.255.240
!
ip default-gateway 10.0.0.49
outsw2
!
vlan 100
name Outside
!
vlan 101
name DMZ
!
vlan 102
name Mgmt
!
interface GigabitEthernet1/0
description To-Inet-rtr2
switchport mode access
switchport access vlan 100
!
interface GigabitEthernet1/1
switchport mode trunk
switchport trunk encapsulation dot1q
!
interface GigabitEthernet1/3
switchport mode trunk
switchport trunk encapsulation dot1q
channel-group 1 mode active
!
interface GigabitEthernet1/4
switchport mode trunk
switchport trunk encapsulation dot1q
channel-group 1 mode active
!
interface Port-channel 1
switchport mode trunk
switchport trunk encapsulation dot1q
!
interface vlan 102
ip address 10.0.0.51 255.255.255.240
!
ip default-gateway 10.0.0.49
Information collection and visualization
Good. Now that we have all the necessary information, we can begin to visualize.
Display process step by step
- Collection of information:
- First, open the configuration file (in this case, ASW1).
- Take from there each ip-address from the sections of the interfaces. In this case, there is only one address ( 192.168.10.11 ) with a mask of 255.255.255.128 . The interface name is vlan250 and vlan 250 is In-mgmt .
- Let's take all the static routes from the configuration. In this case, there is only one (ip default-gateway), and it points to 192.168.10.1 .
- Display:
- Now let's display the information we have collected. First, draw an ASW1 device . ASW1 is a switch, so we use the switch symbol.
- Draw a subnet (tube). Assign it the name In-mgmt , VLAN-ID 250 and the address 192.168.10.0/25 .
- Connect ASW1 and the subnet.
- Insert a text box between the characters ASW1 and the subnet. We display in it the name of the logical interface and ip-address. In this case, the interface name will be vlan250 , and the last octet of the IP address is .11 (it is common practice to display only the last octet of the IP address, because the network IP address is already on the diagram).
- There is also another device on the In-mgmt network. Or at least it should be. We still do not know the name of this device, but its IP address is 192.168.10.1 . We learned this because ASW1 points to this address as the default gateway. Therefore, let's display this device in the diagram and give it a temporary name "??". Also, add its address to the scheme - .1 (by the way, I always highlight inaccurate / unknown information in red, so that looking at the scheme you can immediately understand what needs to be clarified on it).
At this point, we get a circuit similar to this:
Repeat this process step by step for each network device . Collect all information related to IP and display in the same diagram: each ip-address, each interface and each static route. In the process, your circuit will become very accurate. Make sure that devices that are mentioned but not yet known are displayed in the diagram. In the same way as we did earlier with the address 192.168.10.1 . Once you have completed all of the above for all known network devices, you can begin to find out unknown information. You can use the MAC and ARP tables for this (I wonder if it is worth writing the next post telling in detail about this stage?).
Ultimately, we will have a circuit like this:
Conclusion
Draw a logical diagram of the network is very simple, if you have the appropriate knowledge. This is a lengthy manual process, but it is by no means magic. Once you have an L3 network diagram, it’s easy enough to keep it up to date. The benefits are worth the effort:
- You can plan changes quickly and accurately;
- solving problems takes much less time than before. Imagine that someone needs to solve the problem of unavailability of the service for 192.168.0.200 to 192.168.1.200. After viewing the L3 diagram, we can say with confidence that ITU is not the cause of this problem.
- You can easily observe the correctness of ITU rules. I have seen situations where ITUs contained rules for traffic that would never have passed through this ITU. This example perfectly shows that the logical topology of the network is unknown.
- Usually, once the L3 network diagram is created, you will immediately notice which sections of the network do not have redundancy, etc. In other words, the L3 topology (as well as redundancy) is as important as redundancy at the physical level.