Link Aggregation Between Cisco Catalyst and Avaya ERS



    Let's make a small lab. By combining two physical links into one logical link between the switches of two different vendors using the LACP protocol.

    Link Aggregation Control Protocol allows you to combine from two to eight 100 Mbit / s, 1 Gbit / s or 10 Gbit / s Ethernet ports, working on twisted pair or fiber, which allows to achieve a resulting speed of up to 80 Gbit / s. This allows you to increase the bandwidth of the channels and increase their reliability.

    LACP is supported by both vendors, which is why we will use it.

    Despite the existence of the IEEE 802.3ad standard, many companies still use their vendor protocols. In the case of Cisco, this is PAgP. At Avaya, it’s the Northel MLT.

    Combine port 47 and port 48 and let two virtual networks pass through them, for example, for data and for telephony. We will leave the first vlan too.

    Let's start with Cisco.

    enable
    conf t
    

    We create virtual networks. The second vlan for data.

    vlan 2
    name "Data"
    exit
    

    Fifth for telephony.

    vlan 5
    name "Voice"
    exit
    

    We scatter ports on virtual networks.

    1-2 ports will be in the first vlan.

    interface range gigabitEthernet 1/0/1-2
    switchport access vlan 1
    exit
    

    C 3 to 24 we will allocate a voice.

    interface range gigabitEthernet 1/0/3-24
    switchport access vlan 5
    exit
    

    From 25 to 46 for data transfer.

    interface range gigabitEthernet 1/0/25-46
    switchport access vlan 2
    exit
    

    We directly configure port 47 and 48. First, we make them trunked in order to push two virtual networks through them.

    interface gigabitEthernet 1/0/47
    switchport trunk encapsulation dot1q
    switchport mode trunk
    exit
    interface gigabitEthernet 1/0/48
    switchport trunk encapsulation dot1q
    switchport mode trunk
    exit
    

    We now indicate that they are in the same LACP aggregation group. There can be several groups if we want to make several aggregated links.

    interface gigabitEthernet 1/0/47
    channel-protocol lacp
    channel-group 1 mode active
    exit
    interface gigabitEthernet 1/0/48
    channel-protocol lacp
    channel-group 1 mode active
    exit
    

    Assign ip for management.

    vlan 1
    ip address 192.168.1.10 255.255.255.0
    no sh
    exit
    

    Check how it works.

    show etherchannel summary
    

    show lacp neighbor
    


    Now let's get down to Avaya.

    enable
    conf t
    

    By analogy, we create two virtual networks.

    vlan create 2 name "Data" type port
    vlan create 5 name "Voice" type port
    

    Denote that ports 47 and 48 will be trunk. Avaya does not have such a concept. We simply indicate that we will label 802.1Q.

    vlan ports 47,48 tagging tagAll
    

    Add ports to virtual networks. We leave port 1 and 2 in the first vlan, remove the remaining access ports from it. In the fifth, add from 3 to 24 and trunk ports. Accordingly, in the second - ports 25 to 46, plus trunk.

    vlan members remove 1 3-46
    vlan members add 5 3-24,47-48
    vlan members add 2 25-48
    

    Configure LACP. Here, the aggregation group is indicated by the lacp key parameter, you can put any number, most importantly the same.

    interface gigabitEthernet 47
    lacp key 20
    lacp mode active
    lacp timeout-time short
    lacp aggregation enable
    exit
    interface gigabitEthernet 48
    lacp key 20
    lacp mode active
    lacp timeout-time short
    lacp aggregation enable
    exit
    

    Assign ip for management.

    interface vlan 1
    ip address 192.168.1.20 255.255.255.0
    exit
    

    We check.

    show mlt
    

    show lacp port 47,48
    

    Also popular now: